2009年8月アーカイブ

最近、debian squeezeを使っていて、aptitude upgradeしたら kernel が 2.6.30になりました。
VMwareのモジュールのリビルドが必要になったのですが、案の定 コンパイルエラーがでまくりました。 今回は、dazukoも動かなくなったし ちょっと調べてみると 2.6.26から比べるとかなり変わっているようです。ところが、マシンも変えていて ネットワークが  82567LM-3 に変わった為、2.6.27以降でないと認識しないため、2.6.26に戻せないという事態になりました。

とりあえず、VMwareだけでもうごいてくれないと困るので 調べると Adams Bros Blog に パッチがあることがわかりました。 ちょっとバージョンが違うので 手動であてて モジュールをビルドしたら うまく動いたので パッチをあてた ファイルを置いておきます。

vmware-module-sources-6.5.2-156735-2.6.30rc3patched.tar.gz

展開したファイルを インストール後の /usr/lib/vmware/modules/source 以下のファイルと入れ換えてから モジュールのリビルドを行ってください。



2010年12月

      1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31  

このアーカイブについて

このページには、2009年8月に書かれたブログ記事が新しい順に公開されています。

前のアーカイブは2009年6月です。

次のアーカイブは2009年10月です。

最近のコンテンツはインデックスページで見られます。過去に書かれたものはアーカイブのページで見られます。