Top / Linux / Debian / MEMO_No_2

PHP script cannot be executed so often.(PHPスクリプトがしばしば実行できない)

package
squeeze
kernel
2.6.30-1
Date
2009/08/25
Apache
2.2.12-1
PHP
5.2.10

前回 aptitude update で Apache のバージョンを上げてから PHPスクリプトが2回に1回ぐらい実行されずにダウンロードされてしまうという事態が発生しました。squirrelmail,Pukiwiki,Xoopsなどなど PHPを多用しているため大変という事態になってしまいました。apache2ctl configtestでも問題が見つからないし、設定ファイルなどを見直してもおかしなところはわかりせん。

ロードがおかしいのかと考え /etc/apache2/mods-availabelの php5.conf とphp5.loadを見ているうちにおかしなことに気が付きました。 内容は

 LoadModule php5_module  /usr/lib/apache2/modules/libphp5.so

なのですが、"php5_module" と "/usr/lib/apache2/modules/libphp5.so" の間の間隔がちょっと広いようで見てみると TABコードが入っていました。 これを取り除いてapacheを起動しなおすとぴたりとトラブルは収まりました。同定してはいませんが、設定ファイルを読み込むルーチンにバグが入りこんだようです。

ううむ 制御コードが表示されるようにエディタの設定を変えないとだめだなあ。

Comments



トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2009-08-25 (火) 10:02:19 (3312d)